Sign in:
»Forgot your password?

Home | Forum | How to Protect Your Web Form | How to Protect Your Email | Sign Up

Insure yourself from spam! The Anti Spam Insurance Company - ProtectWebForm!

Forum - Using CAPTCHA with WordPress 2.1 on W2K3 server

2007-02-04 07:48:43
Has anyone tried running Smart CAPTCHA with WP 2.1 on a W2K3 web

When I activated the CAPTCHA plug-in on my WP blog my blog totally
disappeared until I removed the CAPTCHA plug-in.

2007-03-01 00:46:00
Yeah I have a similar problem after activating the plugin.
2007-03-27 14:46:29
I've found it doesn't work with WP 2.1.2
2007-04-06 03:53:34
I've been able to use the Wordpress plugin with version 2.1.3 and IIS
5. I did have to make two slight modifications to the
protectwebformcaptcha.php file.

1) Change all opening PHP server blocks from <? to <?php - there are
several of these throughout the php file. This has something to do
with short tags being turned off in the php.ini file, but since I'm
not a php guy, I'm not 100% certain that's the cause.

2) I had to change the referrer URL in the protectwebformcaptcha.php
file, line number 43, from:
$referer = get_settings('home').'/'.get_settings('blogfilename').

$referer = get_settings('home').'/'.get_settings('blogfilename').

The referrer URL is POSTed to when the wrong passcode is entered. IIS
did not care for a post to a non specific page name and would return a
405 error. Just add the index.php to solve that issue.

Otherwise it works great! You can see it in action here:
2007-04-29 02:23:36
Nope, tried that on 2.1.3 and it doesn't work. :-(
2007-04-29 15:39:22
Nope, take that back. Got it to work now, thanks LordsubD. I just had
to change the <? to <?php . I didn't need to change anything else.

Post Reply:

You must be logged in to reply.
Post message

Registered users: 87135

Forms protected: 48551

Further Reading & Anti Spam Resources:


    ©Copyright 2006 All rights reserved. Read our Privacy Policy

Page copy protected against web site content infringement by Copyscape